Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 3,706
Trophies:
1
Hello everyone,

I have 3 Ubuntu 20 servers in my company, all of them were using Samba 4.11 or superior with SSSD authenticating against my AD (Windows Server 2019 AD), with shares working fine. My smb.conf is configured for security = ads. I had ACL permissions in the shares using AD Groups.

I know I know, Samba 4.11+ was not supposed to work with SSSD. But I had it working fine for months.

2 weeks ago, at the same day, all shares stopped working for a reason I do not know. I had to reconfigure Server #1, which was my priority, to use Winbind (ugh) and let company users carry on with their lives. Now I have tested a bunch of different configs for Servers #2 and #3, several combinations of smb.conf and sssd.conf, but haven't been able to get them back and running again. I'm seeing 2 strange errors, on sssd status:


Code:
nov 24 12:19:31 MYSERVER.mydomain.local systemd[1]: Started System Security Services Daemon.
nov 24 12:19:40 MYSERVER.mydomain.local sssd[121856]: ; TSIG error with server: tsig verify failure
nov 24 12:19:40 MYSERVER.mydomain.local sssd[121856]: update failed: REFUSED
nov 24 12:19:40 MYSERVER.mydomain.local sssd[121860]: ; TSIG error with server: tsig verify failure
nov 24 12:19:40 MYSERVER.mydomain.local sssd[121860]: update failed: REFUSED
Which I don't think it's relevant, since SSSD is working fine (I can log into via SSH, and see users through the "id " command).

And in /var/log/samba/ I have the classic winbind not running error:

[2021/11/24 12:03:06.253828, 0] ../../source3/auth/auth_generic.c:125(auth3_generate_session_info_pac )
auth3_generate_session_info_pac: winbindd not running - but required as domain member: NT_STATUS_NO_LOGON_SERVERS

Which I believe is the main problem.

How can I force Samba to use SSSD? I don't understand why it simply stopped working out of nowhere, and the stranger thing is that all of the 3 servers happened at the same day. Could it be a Windows update or something?

I can post my .conf files but as I said, I have tried a lot of different combinations and none of them worked, and I believe it's simply because for some reason my Samba is trying to use Winbind, which he was not supposed to do since it was using SSSD from day 1 of installation.

Thanks for any help!!!
11-24-2021, 12:58 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] passwd not working after editing /etc/shadow oharrisonholmesh 0 2 Yesterday 05:59 PM
Last Post: oharrisonholmesh
  [server] passwd not working after editing /etc/shadow Trogdor 0 2 Yesterday 02:47 PM
Last Post: Trogdor
  LENOVO Legion 5, R5-5600H Wifi not working can make installation work QuailC1945 0 1 12-06-2021 05:50 AM
Last Post: QuailC1945
  How to accelerate the touchpad and the trackpoint on Thinkpad? set-prop not working ebrainpecks 0 2 12-05-2021 12:33 PM
Last Post: ebrainpecks
  [ubuntu] Lenovo v145-15AST screen not working erikduop 0 6 12-04-2021 03:24 PM
Last Post: erikduop
  How to Setup Local DNS Using /etc/hosts - NOT WORKING evolution05 0 15 11-28-2021 11:09 AM
Last Post: evolution05
  [server] Registry setting for Samba in Win10? oharrisonholmesh 0 8 11-27-2021 05:46 PM
Last Post: oharrisonholmesh
  TouchPad & Hibernation Not Working in Lenovo Ideapad S145-15IIL rstefaniacoxa 0 8 11-27-2021 05:15 AM
Last Post: rstefaniacoxa
  [ubuntu] Lenovo T460p - reader fingerprints not working ftishabergers 0 18 11-12-2021 01:35 PM
Last Post: ftishabergers
  Wifi Not Working After Update nandymorenoi 0 16 11-09-2021 11:13 AM
Last Post: nandymorenoi

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2021