Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,165
Trophies:
1
I can't quite figure out where to post this, but it's been a consistent issue for quite a few months so I thought I'd see if I'm the only one.

I have a USB microphone and a USB webcam that I unplug when not in use. While the Ubuntu audio subsystem is getting better about not forcing me to reboot to recognize these devices, Firefox in particular seems to break audio for all applications if it is running during an audio device plug-in or unplug event.

To reproduce the bug:
1. Run Firefox (I am using 91.0b5 (64-bit) but this has been happening for a while).
2. Plug in or unplug a USB webcam with a microphone.

Expected behavior:
New audio device appears and works.

Actual behavior:
Audio generated by Firefox and I believe all other applications (at least Zoom, Chromium, and Signal Desktop, I haven't done this exhaustively) is extremely glitchy and sounds like an audio delay line with massive clipping.

Workaround:
I have to close Firefox and restart it every time I plug in or unplug a USB audio device despite the fact that every other program works fine during switchover.

Other Information:
I suspect this bug may be more general than just unplugging and plugging in audio devices, sometimes I see the audio start to get glitchy simply from opening two tabs that both produce audio. I'm really not sure where to report this bug, whether it's an audio thing, a Firefox thing, or something else. Thanks for any advice!
07-21-2021, 05:57 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Audio problems causing parts of songs to not play basementlivinguk 0 3 Yesterday 10:35 PM
Last Post: basementlivinguk
  [ubuntu] Ubuntu 21.04: libsdl2-dev screws up my whole system Trevor 0 2 07-28-2021 04:11 AM
Last Post: Trevor
  [ubuntu] No USB Drive, need to install Ubuntu (HELP) orileekidd 0 6 07-25-2021 09:26 PM
Last Post: orileekidd
  [ubuntu] Is it possible to backup Mac APFS personal data to Ubuntu server ext4 HDD ? meveliafritzm 0 5 07-24-2021 06:27 AM
Last Post: meveliafritzm
  Bluetooth Hearing aids pair but won't stream audio meveliafritzm 0 4 07-22-2021 12:57 PM
Last Post: meveliafritzm
  [ubuntu] Ubuntu freezes on startup and only using one monitor candremcmillanz 0 14 07-21-2021 05:57 PM
Last Post: candremcmillanz
  [ubuntu] Unable to install Ubuntu 20.04 on system with Windows 10 oonnnasantosi 0 12 07-20-2021 11:29 AM
Last Post: oonnnasantosi
  [ubuntu] Replacement for Compiz Config Settings Manager in Ubuntu 20.04? nteddyflowccsj 0 13 07-19-2021 06:32 PM
Last Post: nteddyflowccsj
  [ubuntu] Diagnosing a freezing Ubuntu PC meloygoodwinq 0 7 07-18-2021 01:17 PM
Last Post: meloygoodwinq
  [ubuntu] Windows suddenly stopped working in a dual boot setup with Ubuntu 20.04 AlisaH2006 0 10 07-18-2021 10:27 AM
Last Post: AlisaH2006

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2021