Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,130
Trophies:
1
My laptop has slow download speeds (compared to upload speeds) when using the onboard (gigabit) ethernet controller versus using a USB3.0 (gigabit) dongle.

The onboard ethernet gives me a download ~50Mbps, but the upload goes up to ~400 Mbps.
The same cable plugged into the USB ethernet dongle gives upload and download of 400Mbps.

I know it's not the systemd/ECN issue because I tested sysctl net.ipv4.tcp_ecn=0 with no effect, and it only happens on the one interface anyway.



lspci on the onboard ethernet shows:


Code:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
ethtool enp2s0 (the onboard controller) shows:


Code:
Settings for enp2s0:
    Supported ports: [ TP MII ]
    Supported link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                        100baseT/Half 100baseT/Full
                                        1000baseT/Full
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000033 (51)
                  drv probe ifdown ifup
    Link detected: yes


lsusb on the dongle shows:

Code:
Bus 002 Device 006: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit Ethernet
ethtool enx00ee22aa659a (the usb dongle) shows:

Code:
Settings for enx00ee22aa659a:
    Supported ports: [ TP MII ]
    Supported link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Half 1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                        100baseT/Half 100baseT/Full
                                        1000baseT/Full
    Link partner advertised pause frame use: No
    Link partner advertised auto-negotiation: Yes
    Link partner advertised FEC modes: Not reported
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 3
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pg
    Wake-on: g
    Current message level: 0x00000007 (7)
                  drv probe link
    Link detected: yes
07-21-2021, 01:00 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Software updater failed to download repository information? jeglin 0 1 Yesterday 04:04 AM
Last Post: jeglin
  [ubuntu] Ubuntu 21.04: libsdl2-dev screws up my whole system Trevor 0 2 07-28-2021 04:11 AM
Last Post: Trevor
  [ubuntu] No USB Drive, need to install Ubuntu (HELP) orileekidd 0 6 07-25-2021 09:26 PM
Last Post: orileekidd
  [ubuntu] Is it possible to backup Mac APFS personal data to Ubuntu server ext4 HDD ? meveliafritzm 0 5 07-24-2021 06:27 AM
Last Post: meveliafritzm
  [ubuntu] Ubuntu freezes on startup and only using one monitor candremcmillanz 0 14 07-21-2021 05:57 PM
Last Post: candremcmillanz
  [ubuntu] Unable to install Ubuntu 20.04 on system with Windows 10 oonnnasantosi 0 12 07-20-2021 11:29 AM
Last Post: oonnnasantosi
  [ubuntu] Replacement for Compiz Config Settings Manager in Ubuntu 20.04? nteddyflowccsj 0 13 07-19-2021 06:32 PM
Last Post: nteddyflowccsj
  [ubuntu] Diagnosing a freezing Ubuntu PC meloygoodwinq 0 7 07-18-2021 01:17 PM
Last Post: meloygoodwinq
  [ubuntu] Windows suddenly stopped working in a dual boot setup with Ubuntu 20.04 AlisaH2006 0 10 07-18-2021 10:27 AM
Last Post: AlisaH2006
  [ubuntu] Dual boot jumps to Windows without showing grub/ubuntu armani5596 0 9 07-17-2021 10:14 PM
Last Post: armani5596

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2021