Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 3,490
Trophies:
1
I am trying to get my netgear a6100 working after upgrade to 21.04. Getting this on the make, need some help installing this again, as it was installed on 20.04 and worked. Thanks.

Leary/rtl8811au modules
make[1]: Entering directory '/usr/src/linux-headers-5.11.0-18-generic'
CC [M] /home/leary/rtl8811au/core/rtw_cmd.o
In file included from /home/leary/rtl8811au/include/osdep_service.h:41,
from /home/leary/rtl8811au/include/drv_types.h:32,
from /home/leary/rtl8811au/core/rtw_cmd.c:22:
/home/leary/rtl8811au/include/osdep_service_linux.h: In function ?_init_timer?:
/home/leary/rtl8811au/include/osdep_service_linux.h:267:8: error: ?_timer? {aka ?struct timer_list?} has no member named ?data?
267 | ptimer->data = (unsigned long)cntx;
| ^~
/home/leary/rtl8811au/include/osdep_service_linux.h:268:2: error: implicit declaration of function ?init_timer?; did you mean ?_init_timer?? [-Werror=implicit-function-declaration]
268 | init_timer(ptimer);
| ^~~~~~~~~~
| _init_timer
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:287: /home/leary/rtl8811au/core/rtw_cmd.o] Error 1
make[1]: *** [Makefile:1848: /home/leary/rtl8811au] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.11.0-18-generic'
make: *** [Makefile:1551: modules] Error 2
[email protected]:~/rtl8811au$
06-11-2021, 02:29 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] Intermittent shutdown errors Shiney 0 10 06-13-2021 11:46 AM
Last Post: Shiney
  Intermittent shutdown errors tamenera91 0 4 06-13-2021 10:32 AM
Last Post: tamenera91
  [SOLVED] rtl8811au errors on make after upgrade to 21.04 tsergiohaynesz 0 9 06-12-2021 12:41 PM
Last Post: tsergiohaynesz
  [ubuntu] What is the script of do-release-upgrade jamescraig 0 11 06-10-2021 04:26 AM
Last Post: jamescraig
  [ubuntu] Upgrade to 21.04 application issues Gerhard1 0 3 06-09-2021 09:51 AM
Last Post: Gerhard1
  [ubuntu] Upgrade dialog too big for display danastacrrzynnt 0 23 06-07-2021 05:37 AM
Last Post: danastacrrzynnt
  How can I make terminal print better organized text? ureddgriffithx 0 15 06-07-2021 05:37 AM
Last Post: ureddgriffithx
  [ubuntu] 21.04 Upgrade Will Not Install Chrome Dome 0 18 06-04-2021 12:14 PM
Last Post: Chrome Dome
  Can i update or upgrade cmake (currrently installed 3.14.0-rc2) in ubuntu 18,how? iclarindaboltona 0 27 06-04-2021 12:14 PM
Last Post: iclarindaboltona
  since 21.04 upgrade, youtube keeps repeating lodiliagloverj 0 23 06-04-2021 10:34 AM
Last Post: lodiliagloverj

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2021