Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,144
Trophies:
1
Hello,

I am running out of ideas on this issue. I have an Ubuntu 20.04 server setup with Docker installed. I am trying to mount a share from my QNAP so that a few of my dockers can read/write to it. On my QNAP I have Windows sharing enabled and NFS. The folder I am sharing has all the read write permissions set, I have set the NFS permissions to R/W NO_ROOT_SQUASH and set the uid/gid to a user and group with R/W access to the share.

If I mount with NFS I am able to write to the share with sudo from my user account but my dockers do not have permissions to write to the share but can read. I have tried setting the dockers to privileged but no luck. So I have tried mounting the share with cifs but writing to the share is a 100% no go no matter what I try, but reading seems to work fine. I am using the same creds as my windows machines that have no issues.

Any thoughts would be greatly appreciated. Below are my 2 different fstab lines.

192.168.0.225:/Video /Docker/movies nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0

//192.168.0.225/Video/ /Docker/movies cifs rw,credentials=/etc/creds,uid=1000,gid=1000,file_mode=0660,dir_mode=07 70 0 0
12-29-2020, 11:59 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Messed ubuntu server 16 keiraleach 0 7 01-14-2021 02:31 AM
Last Post: keiraleach
  [server] sharing samba users tsergiohaynesz 0 5 01-13-2021 06:38 PM
Last Post: tsergiohaynesz
  Windows AD authentication issues dwilliemaemorsea 0 5 01-13-2021 06:38 PM
Last Post: dwilliemaemorsea
  [server] Having issue communicating from Ubuntu 18.04 Virtual Server manastassian 0 10 01-09-2021 01:54 PM
Last Post: manastassian
  [ubuntu] Tacacs+ Server DominiqueM1950 0 6 01-06-2021 07:35 AM
Last Post: DominiqueM1950
  [server] Connecting SAS to SATA nandymorenoi 0 10 12-31-2020 01:49 PM
Last Post: nandymorenoi
  mounted server folders drop off MarisaLla 0 10 12-22-2020 01:44 PM
Last Post: MarisaLla
  [server] Suddenly rejecting only one IP address kyleStyle 0 8 12-22-2020 01:44 PM
Last Post: kyleStyle
  [server] Stability of package versions during LTS release lifespan oonnnasantosi 0 10 12-18-2020 10:22 AM
Last Post: oonnnasantosi
  how to fix permission for ubuntu server installed docker Dogg the Booty Hunter 0 9 12-18-2020 02:32 AM
Last Post: Dogg the Booty Hunter

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2021