Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,405
Trophies:
1
During an upgrade from 16.04 to 18.04 I got 4 error messages or warnings. The upgrade seemed to complete and the system now boots and runs ok but I am now unable to run any package updates. The error messages during the upgrade were:
systemd-shim package not installed post removal script subprocess returned error exit status 2/var/cache/apt/archives/systemd_237-3ubuntu10.39_amd64.deb post removal script subprocess returned error exit status 2systemd-sysv_237-3ubuntu10.39_amd64.deb post removal script subprocess returned error exit status 2The upgrade was aborted. Your system could be in an unstable state. A recovery will now run (dpkg -configure -a)

But it seems like the upgrade was not aborted because the System Information now shows the OS to be Ubuntu 18.04.4 LTS.

Now when I run Software Updater I get this message:
Not all updates can be installed. Run a partial upgrade to install as many updates as possible
There are two buttons: Partial Upgrade and Continue.

If I click Continue I get this:
Software Index is broken. It is impossible to install or remove any software right now. Please use Synaptic or sudo apt-get install -f to fix this issue.
If I then run Synaptic the package systemd-shim is marked to be removed. When I then click Apply I get:
Error systemd-shim. installed systemd-shim package post removal script subprocess returned error exit status 2

If I click Partial Upgrade in the Software Updater it starts to go through the process but I then get:
Could not install systemd-shim
I click Close and other upgrades seem to continue, then right at the end I get:
Could not install the upgrades. The upgrade has aborted. A recovery will now run (dpkg -configure -a). The upgrade has completed but there were errors.

I'd be very grateful for any suggestions to get me out of this situation.

Thanks.
10-21-2020, 10:11 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Unable to pair Bluetooth mouse Shiney 0 1 11-17-2020 04:25 AM
Last Post: Shiney
  [ubuntu] Unable to open NAS folders on LG-NAS danastacrrzynnt 0 3 11-13-2020 03:04 AM
Last Post: danastacrrzynnt
  [ubuntu] 20.10 I need to Request that Ubuntu Upgrade Libreoffice evolution05 0 2 11-12-2020 01:13 AM
Last Post: evolution05
  [ubuntu] Upgrade Ubuntu desktop 18.04 to 20.04 breaks KVM Win 10 guest eevkllriffithl 0 3 11-11-2020 01:52 PM
Last Post: eevkllriffithl
  [lubuntu] saving 32 bit files, to 64 bit distro AshelyP1955 0 1 11-11-2020 01:19 AM
Last Post: AshelyP1955
  [ubuntu] ANSI color change sequences stopped working after upgrade xenial=>bionic eranfields77 0 1 11-10-2020 08:09 AM
Last Post: eranfields77
  Attempts to upgrade from 18.04 to 20.04 result in EFI error blelahharrisc 0 1 11-09-2020 01:21 PM
Last Post: blelahharrisc
  LUbuntu Leave/Shutdown, Leave/Reboot etc question wsusannahmccyyy 0 0 11-09-2020 10:08 AM
Last Post: wsusannahmccyyy
  [lubuntu] Bluetooth transfer speeds of ~50KB/sec bfrankgonzaluuu 0 1 11-07-2020 07:54 AM
Last Post: bfrankgonzaluuu
  [lubuntu] How to copy a file? qkathlinewillish 0 0 11-05-2020 05:40 AM
Last Post: qkathlinewillish

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020