Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,350
Trophies:
1
Dear Friends,

I have tried to install Munge on two computers (comp1 and comp2) with Ubuntu 20.04.1 LTS. I did many trials, but non of them works. The final one was following:

On both mashines, I did:

Code:
export MUNGEUSER=64029
 groupadd -g $MUNGEUSER munge
 useradd -m -c "MUNGE Uid 'N' Gid Emporium" -d /var/lib/munge -u $MUNGEUSER -g munge -s /sbin/nologin munge
 apt-get install munge
 apt-get install libmunge-dev
I generated the key on comp1:

Code:
cd /etc/munge/
 create-munge-key
and copied to comp2:

Code:
rsync [email protected]:/etc/munge/munge.key /etc/munge/
finaly, on botch michenes I did:

Code:
chown -R munge: /etc/munge/
 chown -R munge: /var/log/munge/
 chown -R munge: /var/lib/munge/
 chown -R munge: /run/munge/
 chmod 0700 /etc/munge/
 chmod 0700 /var/log/munge/
 chmod 0700 /var/lib/munge/
 chmod 0700 /run/munge/
 systemctl enable munge
 systemctl start munge
 munge -n | ssh localhost unmunge
The last line worked fine, but non of the folowing:

Code:
[email protected]:/# munge -n | ssh comp2 unmunge
 unmunge: Error: Invalid credential

Code:
[email protected]:/# munge -n | ssh comp1 unmunge
 unmunge: Error: Invalid credential
I checked the UID/GID on botch computers:


Code:
[email protected]:/# cat /etc/group | grep mung
 munge:x:64029:
 [email protected]:/# cat /etc/passwd | grep mung
 munge:x:64029:64029:MUNGE Uid 'N' Gid Emporium:/var/lib/munge:/sbin/nologin


Code:
[email protected]:/# cat /etc/group | grep mun
 munge:x:64029:
 [email protected]:/# cat /etc/passwd | grep mun
 munge:x:64029:64029:MUNGE Uid 'N' Gid Emporium:/var/lib/munge:/sbin/nologin
Do you have any suggestions why it doesn't work?
10-13-2020, 07:40 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Skype instalation problem gandalou1 0 261 01-29-2014 11:26 AM
Last Post: gandalou1
  Ubuntu server instalation wsusannahmccyyy 0 160 12-31-2013 12:07 PM
Last Post: wsusannahmccyyy
  Restore packages list from another Ubuntu instalation medoebler82 0 124 12-04-2013 06:45 PM
Last Post: medoebler82
  [ubuntu] ubuntu 12.04 instalation crash csharolynvargasww 0 130 11-28-2013 08:23 AM
Last Post: csharolynvargasww
  [Lubuntu] Instalation from Apps Directory not working wjeremiahnicholscc 0 165 11-27-2013 06:19 AM
Last Post: wjeremiahnicholscc
  instalation problem with cairo dock for ubuntu 13.04 Hill3530 0 183 11-25-2013 05:58 PM
Last Post: Hill3530
  [xubuntu] opensource driver; better 3D support in 64-bit instalation, then 32.bit MarvinR1935 0 166 11-25-2013 05:58 PM
Last Post: MarvinR1935
  [ubuntu] Netgaer wireless instalation mw7smartc 0 128 11-18-2013 03:53 AM
Last Post: mw7smartc
  [lubuntu] lubuntu problem instalation Hill3530 0 145 10-02-2013 04:59 AM
Last Post: Hill3530
  ubuntu 13, 32 or 64 bit: wireless works fine after instalation but after reboot... Bergerac 0 125 09-21-2013 03:40 PM
Last Post: Bergerac

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020