Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,154
Trophies:
1
I have openssh running for sftp. Following online guides I have this working with the user chrooted to their home directory. What I like is to have a second user (user2-download-only) to be chrooted to user1 home directory for read only access. Typical scenario would be user uploads file and sends read-only credentials to client. I would normally "usermod -d /home/user1 user2".

Current procedure:
sudo adduser bob
sudo usermod -G sftpusers bob
sudo chown root /home/bob
sudo chmod go-w /home/bob
sudo mkdir /home/bob/public
sudo chown bob:sftpusers /home/bob/public
sudo chmod ug+rwX /home/bob/public
usermod -s /sbin/nologin bob

sshd_config
Match Group sftpusers -->Edit corrected typo
ChrootDirectory %h
ForceCommand internal-sftp
09-29-2020, 01:02 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Cannot connect to specific Wi-Fi (home network) DesiraeH1999 0 2 Yesterday 05:12 AM
Last Post: DesiraeH1999
  Ubuntu 18.04, shorcut for taking screenshots to Pictures folder/clipboard not working QuailC1945 0 7 10-15-2020 03:13 PM
Last Post: QuailC1945
  Home Folder has Puked All Over the Desktop DominiqueM1950 0 3 10-07-2020 09:15 PM
Last Post: DominiqueM1950
  [ubuntu] "groups" CLI gives group or user ? jindymas11 0 2 10-05-2020 01:18 PM
Last Post: jindymas11
  [SOLVED] HP 5Si printer not visible on network Fganly216 0 2 09-26-2020 04:18 AM
Last Post: Fganly216
  Closing a folder right after opening a file CynthiaA1962 0 6 09-24-2020 09:37 AM
Last Post: CynthiaA1962
  [SOLVED] Installation Not Seeing Files cadenadaltoni 0 16 09-14-2020 11:41 PM
Last Post: cadenadaltoni
  [SOLVED] Permission denied in Glimpse (probably a snap install issue?) Wilma 0 24 09-02-2020 04:42 PM
Last Post: Wilma
  [ubuntu] Configure virtual users in vsftpd on ubuntu 18.04 vfreddyhuynhp 0 11 09-02-2020 10:32 AM
Last Post: vfreddyhuynhp
  [SOLVED] ibus won't start after upgrade to 20.04 orileekidd 0 19 09-01-2020 12:33 AM
Last Post: orileekidd

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020