Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,287
Trophies:
1
Hello,
I recently acquired an Acer Spin 3 SP314-54N, it is a great laptop however i'm rather a big fan of linux so very soon after i got it i installed ubuntu on here (my end goal was kubuntu but i had a usb with ubuntu laying around) after messing around with the storage mode, switching from intel RST to AHCI, it worked and booted up smooth, however neither my touchscreen or trackpad work. I managed to fix the trackpad by changing the trackpad mode from IC2 to PS2 however the touchscreen still doesn't work because from what i've looked up the touchscreen is reliant on IC2 (i think i'm not sure), someone with the bigger brother to my laptop, the spin 5 managed to fix it by entering in "i8042.nopnp=1 pci=nocrs", that might not be precisely it as i just read it off a scribbled note, they put it into the grub when they booted it up, inbetween "splash" and "_ _ _", which i can't find when i go to the grub menu and press e on the grub, i'm pretty stuck and it would be a bummer not being able to use the touchscreen.

Thanks,
Zdos123

p.s. i've tried different kernels my current one is the default Kubuntu kernel 5.4.0-42-generic
09-24-2020, 07:39 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Dual boot with Windows 10 not working Wilma 0 3 10-22-2020 05:04 AM
Last Post: Wilma
  [kubuntu] reset network after losing connection dwiltonmorrisonl 0 1 10-20-2020 05:23 PM
Last Post: dwiltonmorrisonl
  Ubuntu 18.04, shorcut for taking screenshots to Pictures folder/clipboard not working QuailC1945 0 8 10-15-2020 03:13 PM
Last Post: QuailC1945
  not used to touchpad behavior using kernel 5.x oonnnasantosi 0 6 10-12-2020 06:40 PM
Last Post: oonnnasantosi
  network card not working after upgrading from 18.04 to 20.04 kalundo38 0 4 10-10-2020 06:26 AM
Last Post: kalundo38
  Anyone gotten Jami working on Ubuntu? xkentonhenslyyy 0 5 10-06-2020 01:14 PM
Last Post: xkentonhenslyyy
  Converting PCL file to PDF on Ubuntu system - ghostpcl not working - alternatives? SachaL1999 0 3 09-29-2020 04:44 PM
Last Post: SachaL1999
  [kubuntu] VLC not working if network is blocked by firejail? keiraleach 0 4 09-29-2020 01:02 PM
Last Post: keiraleach
  [ubuntu_studio] How to eliminate unwanted, not working, system entries in autostart ? justinbray9 0 21 09-05-2020 12:50 PM
Last Post: justinbray9
  [ubuntu_mate] Check if microphone is working AlecH1969 0 20 08-27-2020 12:47 PM
Last Post: AlecH1969

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020