Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,368
Trophies:
1
This is a new installation (not an upgrade). The OS runs from a USB thumbdrive (32G). I installed mysql-client, and then tried to install mysql-server but the installation failed. Here's the error.log:

https://paste.ubuntu.com/p/zhVbd5n75r/

A couple of deviations are the /var and /tmp directories are links to directories on a harddrive (to avoid excessive read/write to the thumbdrive). The ownership and permissions of the linked-to directories are the same as original. Correction: /var was not linked!

From the error.log file:

Code:
2020-05-26T18:41:56.297387Z 0 [Warning] [MY-011810] [Server] Insecure configuration for --pid-file: Location '/tmp' in the path is accessible to all OS users. Consider choosing a different directory.
Not sure why this comes up as the actual /tmp directory has permissions "drwxrwxrwt" with root:root ownership.

From the error.log file:

Code:
2020-05-26T18:41:06.571075Z 6 [Warning] [MY-010453] [Server] [email protected] is created with an empty password ! Please consider switching off the --initialize-insecure option.
How do I turn it off? If I don't and successfully install with no root password, can I then run mysql as root with the command "mysql -u root"?

From the error.log file:

Code:
2020-05-26T18:41:55.732794Z 0 [ERROR] [MY-011300] [Server] Plugin mysqlx reported: 'Setup of socket: '/var/run/mysqld/mysqlx.sock' failed, can't create lock file /var/run/mysqld/mysqlx.sock.lock'
Is this a result of having /var as a linked directory (Correction: It's not)? I'd rather not, but I could create a couple of harddrive partitions and mount them on /var and /tmp.
05-26-2020, 05:56 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [UbuntuGnome] Can't remove failed printer qkathlinewillish 0 3 10-22-2020 01:27 AM
Last Post: qkathlinewillish
  Initramfs unpacking failed: Decoding failed then black screen blinking cursor qkathlinewillish 0 5 10-17-2020 01:01 AM
Last Post: qkathlinewillish
  Failed NAS Ice Queen 0 9 10-13-2020 12:19 PM
Last Post: Ice Queen
  [ubuntu] Wifi unable to connect after failed docer install attempt orileekidd 0 7 09-26-2020 02:04 PM
Last Post: orileekidd
  Need installation cd for HP 4470C Scanjet DominiqueM1950 0 9 09-25-2020 04:57 AM
Last Post: DominiqueM1950
  Need installation software for HP4470 scanjet FrancheskaF 0 7 09-25-2020 04:57 AM
Last Post: FrancheskaF
  Wordpress Theme Installation Error Hill3530 0 13 09-17-2020 03:24 PM
Last Post: Hill3530
  [ubuntu] AMD GPU Installation itsmeamandaneode 0 14 09-14-2020 11:41 PM
Last Post: itsmeamandaneode
  [SOLVED] Installation Not Seeing Files cadenadaltoni 0 18 09-14-2020 11:41 PM
Last Post: cadenadaltoni
  [ubuntu] What went wrong during this application installation? Mac Tramp 0 19 08-31-2020 07:44 PM
Last Post: Mac Tramp

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020