Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,276
Trophies:
1
hi,

I build gcc 9.2 from source and installed into /usr/local in Ubuntu 19.10. After that I am no longer able to log in using unity-desktop. After log-in an error message flashes up, too fast to see then it returns to the login screen. I am able to log into gnome desktop, however.

I tried to repair it with the following steps:


Code:
sudo dpkg -r mygccbuild
sudo rm -rf /usr/local/bin/gcc
sudo rm -rf /usr/local/lib/gcc
then reinstalled with

Code:
sudo apt install --reinstall gcc
sudo apt install --reinstall ubuntu-unity-desktop
after a restart, this resolved apport-gtk from crashing. Everything behaves normal, no errors or buggy behaviour but again, logging into unity is still failing.

any ideas what else I can try? Also I thought I'd be fine installing gcc into /usr/local, why is it interfering with system environment?
01-16-2020, 09:57 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Trying to install Ubuntu 19.10 but can't type to create login details PatrickSan1980 0 9 01-31-2020 02:27 PM
Last Post: PatrickSan1980
  [xubuntu] Fresh Xubuntu install, no sound, cant play videos. justinbray9 0 12 01-15-2020 05:31 AM
Last Post: justinbray9
  Unable to Install Metatrader4 on Ubuntu 12.04 LTS vfreddyhuynhp 0 13 01-13-2020 10:56 AM
Last Post: vfreddyhuynhp
  [SOLVED] Unable to install 19.10 start_image() returned Invalid Parameter keiraleach 0 39 11-03-2019 11:31 AM
Last Post: keiraleach
  [lubuntu] Trying to Install SETOOLS on 32bit LUBUNTU bfrankgonzaluuu 0 30 11-01-2019 04:05 PM
Last Post: bfrankgonzaluuu
  Xubuntu 19.04 cannot install DominiqueM1950 0 30 10-13-2019 06:06 PM
Last Post: DominiqueM1950
  How do I install a missing library? linlynn80 0 26 10-11-2019 12:11 AM
Last Post: linlynn80
  [server] Linux Server always booting to grub rescue after install Shiney 0 43 10-03-2019 01:58 AM
Last Post: Shiney
  failed to use Boot Repair on freshly installed UEFI Windows 10 and UEFI Ubuntu 18 oonnnasantosi 0 33 09-20-2019 01:57 AM
Last Post: oonnnasantosi
  [ubuntu] how to install and use ID 1f4d:0237 G-Tek Electronics Group usb tv tuner zbernadinerrrhat 3 769 09-21-2018 11:26 PM
Last Post: Monday12

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020