Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,378
Trophies:
1
I am running Ubuntu 18.04 on a Lenovo ThinkPad E555 laptop.

A few weeks after the installation, some (but not all) of my keys have suddenly become "remapped" to "junk sequences". Specifically, the i, k, and comma keys.

When I press i, the sequence `q*ew6r` is printed. When I press k, the sequence `a7ds2fjk` is printed. This problem persists after reboot and occurs in all applications.

I have ruled out a hardware issue, as my Win 10 dual boot works fine. After reinstalling Ubuntu 18.04, the keys worked fine again for some time, but the problem has now recurred for a second time.

I have tried the following:

Resetting the console and keyboard configuration: `sudo dpkg-reconfigure -plow console-setup` and `sudo dpkg-reconfigure keyboard-configuration`.Verifying that I do not have conflicting keyboard layout and language settings.When I execute `showkey -k` to test my keyboard, pressing the i and k keys register the same key sequences that I gave above.I verified num lock is offI booted into a live CD, and the i,k, and comma keys work correctly.

Given the above troubleshooting, I believe that some sort of configuration has been corrupted, perhaps by a package update?

I understand that there are many layers between a keypress and the final processing of that keypress, and I would appreciate some guidance about how to troubleshoot this.

Thank you for your help - both for this issue (my first actual post!) and for all the fantastic responses to other posters that have helped me over the years.
11-09-2019, 04:05 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Ubuntu/Ubuntu file sharing for non-admin users? AvyeC1990 0 24 11-03-2019 11:31 AM
Last Post: AvyeC1990
  [ubuntu] My CTRL, Windows and ALT keys are working as Shift Wilma 0 279 09-14-2018 02:15 PM
Last Post: Wilma
  Invalid character (&) in display serial causes libmutter crash dgalinaalvaradoj 0 137 07-20-2018 10:13 AM
Last Post: dgalinaalvaradoj
  [ubuntu] Arrow keys and delete not working, strange window pops up MarvinR1935 1 170 06-20-2018 04:58 AM
Last Post: Meeniwo9471
  [lxde] After remapping keys capslock light does not work joaltun85 0 111 06-01-2018 12:12 AM
Last Post: joaltun85
  [xubuntu] terminal not using ssh keys Gerhard1 0 117 02-10-2018 10:47 PM
Last Post: Gerhard1
  [kubuntu] 107 keys keyboard does not trigger slash/question mark key event linlynn80 0 181 12-12-2017 03:34 PM
Last Post: linlynn80
  [ubuntu] Forgotten GPG passphrase, want to generate new keys etc medoebler82 0 241 04-21-2016 11:19 AM
Last Post: medoebler82
  [ubuntu] 12.04.4 LTS -- Modifier keys not working gmelissaleachr 0 203 02-10-2014 08:42 PM
Last Post: gmelissaleachr
  Number pad keys wont work MarisaLla 0 217 02-08-2014 06:14 AM
Last Post: MarisaLla

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2019