Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,153
Trophies:
1
I wanted to try and get LemonPOS set up.

I'm following instructions from this post which reads as follows:

Quote:



October 20th, 2011 #6
Motovista
First Cup of Ubuntu

Here is how I did it in Kubuntu:

Terminal command- sudo apt-get install mysql-client mysql-server

download Lemon POS from Software Repository

Terminal command- cd /usr/share/kde4/apps/lemon/

Terminal command- cat lemon_mysql.sql | mysql -u root -p

Reboot and open Squeeze. There will be a username and password on the screen that logs into the database. Leave that alone. I think this is where most people (I did) have issues with the program, because they think they are supposed to put their mysql password or the default lemonpos username and password there.

Where you are asked for a user name and password, use admin and linux.



I installed LemonPOS and Squeeze from the 18.04 repos.
I understand that the software is old and unmaintained, as the wiki links for it are gone and the domain for sale.

Anyway.

My underlying problem is with mySQL.
I don't remember being prompted for a password at install.

I have run the following to change my root mySQL password:

Code:
sudo mysql_secure_installation
I've run CD to get to /usr/share/kde4/apps/lemon

When I run:

Code:
cat lemon_mysql.sql | mysql -u root -pls
I get the return of:

Code:
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
When running the same as sudo:

Code:
sudo cat lemon_mysql.sql | mysql -u root -pls
I get the return:

Code:
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1698 (28000): Access denied for user 'root'@'localhost'
Then, a Sudo password prompt, and a return of new line.

Running LemonPOS at this stage gives me a warning that it could not connect to database, and the logout function fails. So, I have to kill it with CTRL+ALT+ESCAPE.

I know what my mySQL root password is. But, I'm never prompted for it.

I know I'm missing something. I just don't know what.

Any clues?
09-25-2018, 10:57 PM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] How to get 4od working in Ubuntu and Xubuntu gandalou1 5 839 09-20-2018 10:47 PM
Last Post: Monday12
  [xubuntu] Enabling BG phonetic keyboard in xubuntu Hoppytramp 2 498 09-20-2018 09:12 PM
Last Post: Monday12
  Panasonic Toughbook CF-19 touchscreen calibration issue sjaimefrederickv 0 166 09-19-2018 05:03 AM
Last Post: sjaimefrederickv
  [ubuntu] WOL killer E2200 issue 4.15.0-34-generic // Ubuntu 18.04.1 LTS QuailC1945 0 117 09-12-2018 11:32 PM
Last Post: QuailC1945
  [xubuntu] Slow boot in xubuntu 18.04 erikduop 0 205 09-10-2018 10:16 PM
Last Post: erikduop
  [xubuntu] Using journalctl to narrow down a Wi-Fi problem? nandymorenoi 0 209 09-06-2018 03:49 AM
Last Post: nandymorenoi
  [ubuntu] Install encrypted software RAID 1 on Ubuntu server - issue vbasilshawh 0 273 09-05-2018 06:20 AM
Last Post: vbasilshawh
  [xubuntu] Replacing Thunar messed up desktop file operations QuailC1945 2 524 08-31-2018 10:24 PM
Last Post: Monday12
  [xubuntu] USB TV Capture Card Not Working mw7smartc 1 608 08-31-2018 09:38 PM
Last Post: Monday12
  [xubuntu] Ricoh SP 3200SF don't work tsergiohaynesz 0 126 08-29-2018 09:28 PM
Last Post: tsergiohaynesz

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2019