Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,173
Trophies:
1
Okay. I've got several years of experience in Linux so I'm not actually a newbie. I've used Linux Mint for several years and am now using Ubuntu (same HOME-partition).

My computer consists of 3 harddrives. I've got an ssd containing only the system, a 1.8 TB harddrive split up into several partitions containing HOME-partition, DATA-partition, "Windows 10"-partition and data-partition to Windows and the a 300 GB Maxtor harddrive for data.

To get some sort of privacy I'm using VeraCrypt on several partitions.

Now the initial symptoms:
my system has during a long period of time (months) taken more that 1 minute to load. To fix that I tried several options in the BIOS (motherboard H81M-D PLUS). But nothing helped.

A deeper explanation of the long boot-time is several second between power on and going into actual reading from the harddrives / boot-menu appearing. I couldn't figure out what caused this initial booting to take such a long time. So I though maybe it was some update from Ubuntu that made the system search a long time for information (a security-update maybe). So I figured maybe some security-update now was forcing me to update my configuration from a MBT to GPT. So I made the system convert all the MBRs on my harddrives.
All the conversions went great except my 300 GM harddrive. There was some sort of minor error during the conversion so I had to cancel the conversion (later on I managed to convert it through a GUI-utility, though).

Now the real heavy issue. This 300 GB harddrive consists of only 1 VeryCrypt-file. This file doens't exist on the partition anymore (all the space of the partition is free). As I haven't deleted anything I conclude that the index of the files on the partition is corrupt (MBR -> now GPT). That's why I've tryed several recovery-options:
* gfisk (recover mbr, convert mbr to gpt, search for lost information)
* testdisk (both recovery of files and the partition [I've got experience in using testdisk -> a year ago I managed to recover 1 TB from an external harddrive that a paid, recognized computer-forensic-shop wasn't able to recover]). But testdisk isn't able to find any partition or files.
* I ran Photorec which found some files of difference format. But as I knew that the partition was only 1 big VeraCrypt-file I canceled the search by PhotoRec as that utility apparently looked deeper down the filestructure of the partition (discovered files laying below the VeraCrypt-image).

What am I to do to save my data?

I've located another utility (extundelete-0.2.4) but haven't tested it yet.

By the way: my 1.8 TB harddrive is rather new and all the states of several programs tells me that it functional and isn't faulty in any way.
Never the less my partitions get some sort of filesystem-error now and then. When I have to make a hard reset of my system (sometimes Ubuntu 18.04 freezes) I have to fix it the hard way. And then my system won't boot after completing the BIOS. It states something about a usb-setting in one line in terminal. Then a couple of seconds later it prints another line of information about the same thing (USB). And then another line and continues like that.
To fix this issue I first reinstalled Ubuntu and everything was alright. But after a few bootups the situation was back.
To figure out a new fix I tried booting into recovery-mode and fix the file-system here. But somehow the computer freezed up in this process. And if I managed once in a while to get to the login-screen in normal bootup and tried to login the system logged me in alright but after 1 second I transferred be right back to the login-screen like I wasn't logged in. And now I could continue this process over and over again not getting out of the situation. When I tried this I noticed some sort of counter appearing on screen when logged in before I was transferred back to the login-screen (this happeded in recovery-mode, too). I figured out that this was some sort of check of the file-system that didn't complete. So my solution was to boot into the Ubuntu installations-USB and run a check on my harddrives here. Here I was able to discover errors in the filesystem (on both the system-partition (ext4) and the HOME-partition (ext4)) and to fix them. Afterwards I am able to boot normally.
Strange enough this problem occurs pretty often and the fix is always the same (taking a long bootime to boot into the Ubuntu-installation, too, from BIOS).

So somehow my ext4-partions often get some sort of file-structure-error although I shutting down the system as supposed to.
(I got both ufw and Sophos Antivirus with realtime-protection installed).

Now what am I to do?

My main concern at the moment is to get my VeraCrypt-file contain data from the 300GB partition back.

Any help will be greatly appreciated :-)

PS:
testdisk states among other things about the 300 GB partition:
Warning: number of heads/cylinder mismatches 2 (FAT) != 255 (HD)
Warning: number of sectors per track mismatches 18 (FAT) != 63 (HD)

PPS:
I've installed all updates to Ubuntu 18.04 including kernels.
08-25-2018, 05:26 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Resize partition sbrantalvarmmoe 1 157 03-27-2020 06:11 PM
Last Post: FrankJScott
  [ubuntu] Deleted Partition - Desperate help needed! PaulMallow 1 140 03-04-2020 12:22 AM
Last Post: FrankJScott
  [all variants] Retro Encrypting Ubuntu Live Persistent USB Casper Partition vfreddyhuynhp 0 27 02-11-2020 05:22 AM
Last Post: vfreddyhuynhp
  What is the default size of root, swap and home partition? jeglin 0 23 01-15-2020 05:31 AM
Last Post: jeglin
  [ubuntu] Dual-boot Windows partition recently started mounting as read-only lonniedivers 0 33 12-26-2019 05:09 PM
Last Post: lonniedivers
  [ubuntu] Unable to find what's wasting all my partition storage joaltun85 0 38 12-11-2019 05:02 PM
Last Post: joaltun85
  Deleted ubuntu partition now I cant boot CynthiaA1962 0 64 11-09-2019 04:05 AM
Last Post: CynthiaA1962
  Issues with GlusterFS mounted Partition and permissions Bakker 0 28 10-23-2019 04:06 PM
Last Post: Bakker
  Creation of partition in laptop Ice Queen 0 33 09-30-2019 05:08 AM
Last Post: Ice Queen
  Unable to format partition CynthiaA1962 0 40 09-29-2019 03:46 AM
Last Post: CynthiaA1962

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020