Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,401
Trophies:
1
Hello!

I have a setup that exists out of an apache2 load balancer that balances to two webservers.
The following is my balancer setup:


Allow from all
# cluster member 1
BalancerMember http://172.16.100.190:80 route=1

# cluster member 2
BalancerMember http://172.16.100.191:80 route=2

ProxyPass /balancer-manager !
ProxyPass / balancer://cluster/ stickysession=ROUTEID

This works for my site in /var/www/
But I have multiple directories inside my /var/www -> /var/www/site1 /var/www/site2 , ...
And I cannot figure out how to load balance to those directories.
I tried reverse proxy to the sites:

ProxyPassReverse / http://172.16.100.190/site1
ProxyPassReverse / http://172.16.100.191/site1

That did not work. nor did, using the servername from the site work

ProxyPassReverse / http://site1/

Is there a kind soul out there that knows the solution to this problem?
03-12-2013, 11:18 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [ubuntu] Can UEFI system manually load a Legacy O/S lailacoleman7 0 17 07-31-2020 05:15 AM
Last Post: lailacoleman7
  [ubuntu] How to redirect apache traffic through PPTP VPN evolution05 0 30 05-21-2020 07:41 AM
Last Post: evolution05
  Nvidia fails to load after sleep Bakker 0 25 05-03-2020 04:18 AM
Last Post: Bakker
  Can't access Apache on VM from Host! lonniedivers 0 27 04-24-2020 04:14 AM
Last Post: lonniedivers
  [ubuntu] apache down after lts upgrade ijeffflowersg 2 395 03-12-2020 08:30 PM
Last Post: FrankJScott
  [ubuntu] Load balancing tintan253 0 39 03-08-2020 04:07 AM
Last Post: tintan253
  [server] Server Load Going Through the Roof ocolebrightn 0 38 02-22-2020 07:53 AM
Last Post: ocolebrightn
  lubuntu 17.10 -> 18.04 : apache shows php source code instead of processing the php AvyeC1990 0 199 07-26-2018 05:23 AM
Last Post: AvyeC1990
  [ubuntu] libGL error: failed to load driver: nouveau meveliafritzm 1 432 06-22-2018 03:50 AM
Last Post: Monday12
  [ubuntu] gnome-system-monitor will not load Hill3530 1 429 06-21-2018 09:57 PM
Last Post: Monday12

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020