Forums Search Login Register
Login
Username
Password
New Posts Todays Posts Find Users Posts Unanswered Threads Help Mark Forums as Read

Thread Options  Subscribe to this thread Subscribed Users  Add Reply 
Posts: 1,351
Trophies:
1
Howto install( transfer) Lubuntu in(to) HP Spectre xt 13''

Recently bought one ultrabook HPSpectre XT 13'' from Harvey Noman online store , couldn't get used toWindows 8 and decide to stick with Lubuntu which been put on my Aceraspire one D255e netbook.

As my place is quite rural, postdelivery and internet broadband is always a problem for me. At themoment I use Vodafone mobile broadband 2GB data plan, every time whenI got something to download , I just can't make a heart to get itstraightaway from internet, big stuff like a .iso file or a importanthug patch I will get them in public library when I am off from work.Limited situation leads me to transfer Lubuntu onto my brand newultrabook.

My installation plan is roughly asfollow:

1 copy the windows 8 64bitproduct key on a piece of paper for the possible future use

2 backup all my personaldocuments in /home partition to a NTFS partition

3 empty all the files inDownloads Music Document Picture folders

4 clear up all the cachefiles,trash can, temporary folder and anything is not useful(probably need to get the root authority by run **sudo pcmanfm**in Terminal ), or use Bleachbit to delete rubbish.

5 use Ucloner 10.10.1 to back upall my Lubuntu 12.04 to a squash file (.squashfs) like Ghost inwindows.
might need install python-vte (sudoapt-get install python-gtk2 zenity python-vte) andsquashfs-tools ( same as above:sudo apt-get installsquashfs-tools), Check the instruction 说明.txtout.
**cd /ucloner/porgram/, thensudo ./ucloner_gui.py**
you will figure it out in the GUIwindow, I prefer to use a separated partition which is neither / nor/home as destination , a sole ntfs path or one removable hard diskwill do.

Another choice is Clonezilla, made byTaiwanese, but not very friendly to use, you can not restoreinto a smaller partition with image file which is backup from abigger partition.

6 boot my hp spectre xt 13 withpressing ESC button,go F10 for bios ,set up to legacy support modeto disable UEFI mode, save and reboot, pressing F9 to select lubuntulive usb as the boot disk.

7 use live usb (can be made byUnetbootin in *buntu or yumi-multiboot-usb-creator inwindows) to erase all the stupid windows' and hp rubbish in my 128GBSSD( occupy nearly 60GB data!) then get the partitions sorted byGparted,sda1 20GB for /, sda2 4GB for swap, sda3 50GB for/home,rest of the disk for NTFS.

8 use Ucloneragain( do not extract to a Fat32 partition, extract to a NTFS or aext4 partition which you have authority to execute), restore all thedata from the .squashfs you saved. choose the proper path for yourown use.

9 restart, looks everything inmy acer netbook is coming back, no more blue screens in linux world!
you can copy all your personaldocuments though samba.

Modifyfew bugs in Lubuntu 12.04

After playing around for a while, foundquite a few unacceptable bugs. My machine is too new to suit theLubuntu 12.04. and the frustrating thing is you can find nothinguseful about linux on the damn hp website.

#1 touchpad has noright click

The easiest way I find on Ubuntu forumis :

1. Create 51-clickpad.conf in/etc/X11/xorg.conf.d directory. Note that xorg.conf.d directory didnot exist for me so I had to make the directory.
2. Put the following lines in51-clickpad.conf

Section"InputClass"
Identifier"Default clickpad buttons"
MatchDriver"synaptics"
Option"SoftButtonAreas" "50% 0 70% 0 0 0 0 0"

EndSection

Actually the conf from the forum islonger than this, and I found the extra lines just not work very well on Hp spectre xt 13'', and in the option ''softbuttonArea'' , Ichange the right click area to 70% above instead of the original 82%.

logout then login again, the rightclick is back. another clickpad problem is the left top function, Ihaven't figure it out yet. hopefully I can find the newest patch forthis bug.

#2 Beatsaudio only have two frontspeakers working

1 check this link to install andupdate alsa to v1.0.25

http://droid-hive.com/index.php?/topic/9...oslubuntu/

2 download the hda-jack-retask deb package(for intel hda) from
https://launchpad.net/~diwic/+archive/hda/+packages

3 after installation, **sudohda-jack-retask** in terminal , select codec IDT 92HD99BXX andselect show unconnected pins

4 make sure the configuration is asfollow:

pinID : 0X0a override microphone
pinID: 0X0b override headphone
pinID: 0X0c override microphone
pinID: 0x0d override internalspeaker
pinID: 0x0f override internalspeaker
pinID: 0x11 override internal mic

apply now, may pop out a error window,ignore it and install boot override

5 reboot, open alsamixer interminal, make sure speaker and speaker1 is not on mute and the twocapture is on as well.

6 now,play your favourite music, rockout!

Probably you need to try snd-hda-intelmodel=ref option ( **gksu gedit /etc/modprobe.d/alsa-base.conf**),good luck.

#3 optimize ssd for Lubuntu

follow this link:https://sites.google.com/site/easylinuxtipsproject/ssd

#4 card reader driver

lspci in terminal:

02:00.0 Unassigned class [ff00]:Realtek Semiconductor Co., Ltd. Device 5229 (rev 01)

grub the driver from :

http://www.realtek.com.tw/Downloads/down...Down=false

extract then go into the path where youextracted by cd ***/rst5229

Build Steps
===========

1) make
2) make install
3) depmod
4) reboot your computer

Note: Root privilege is required instep 2 and 3

#5 intel 6235 wireless is too slow

lspci in terminal

Network controller: Intel CorporationCentrino Advanced-N 6235 (rev 24)

Lots of people said there is somethingwrong with the driver, and disabled 11n will solve the bug, but Idon't think so. if you use the wireless with the AC power plugged in,everything is good. Once laptop runs on battery, the wireless will bebloody slow, at this time if you ping the router in your home, thelatency(communication delay) is above 50ms sometimes, what the....!Definitely the power management is the bugger.

Temporary solution is run sudoiwconfig wlan0 power off in the terminal, but you also can turnit off by create a wireless script to turn it off permanently:

cd /etc/pm/power.d (if itdoesn't exist, sudo mkdir /etc/pm/power.d to create one)

create a wireless file and type twolines in:

#!/bin/sh

/sbin/iwconfigwlan0 power off

save and reboot, problem solved!

# 4GB memory support in 32bitlubuntu

sudo apt-get installlinux-generic-pae linux-headers-generic-pae

I just gather all the informationtogether, this is pretty much most of issues about hp spectre xt13''in Lubuntu 12.04. Hopefully this can help somebody.
03-12-2013, 03:50 AM
Reply
Subscribe to this thread Subscribed Users  Add Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Problems installing LUbuntu 20.04.1 from scratch CynthiaA1962 0 2 10-17-2020 01:12 PM
Last Post: CynthiaA1962
  shortcut alt+F10 does not work in Lubuntu 18.04 meloygoodwinq 0 3 10-12-2020 09:52 AM
Last Post: meloygoodwinq
  [lubuntu] Problems with my printer nandymorenoi 0 1 10-07-2020 02:49 PM
Last Post: nandymorenoi
  Only thing on install 20.04 checked was Powershell but can't get it to work. nandymorenoi 0 2 10-01-2020 02:39 PM
Last Post: nandymorenoi
  [ubuntu] Wifi unable to connect after failed docer install attempt orileekidd 0 6 09-26-2020 02:04 PM
Last Post: orileekidd
  [lubuntu] Internal drive partitions listed as removable sbrantalvarmmoe 0 3 09-26-2020 04:18 AM
Last Post: sbrantalvarmmoe
  [ubuntu] Install Ubuntu outside the PC target Gerhard1 0 3 09-25-2020 01:45 PM
Last Post: Gerhard1
  Grub And Audio problem after fresh install blesleystanleyz 0 14 09-16-2020 09:46 AM
Last Post: blesleystanleyz
  [server] Beginner having install trouble erikduop 0 15 09-12-2020 03:24 AM
Last Post: erikduop
  [SOLVED] Permission denied in Glimpse (probably a snap install issue?) Wilma 0 24 09-02-2020 04:42 PM
Last Post: Wilma

Forum Jump:



User(s) browsing this thread: 1 Guest(s)



Contact Us Privacy Policy Top RSS
Forum Software By: MyBB, © 2002-2020